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Neuron Livelink UE Plugin v1.3.4
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o HIFEL]5|EERA4.26 427 5.05.15.25.3

AFRIFIANEER (PWRERERER) s EREEUE (SEEININVPSIE)
RN EFEAT-Posel ENEHEZEZS (ELAN{ERA-Pose) RITEEY
SEHEIFIRM R AXis StudioRIERIH B AIBHIEUE

[Axis StudioZIEFEFIFES

1.2 S8laRE
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Mame

Config

Content LiveLinkTestd24 1 » Plugins
Intermediate

" Plugins | e

Caved B create 3 folder and name it as Plugins NeuronLivelink424 9e272b6
@ MeuronlLivelink.uproject
9 add NeurcnLivelink to Plugins folder

Bl R UL -
1. f#Plugins H 3¢
2. #MNeuronLiveLinkddiff HxX CIE4E) #IPlugins H 3k

3. ELJSIETiEgE

1. HFHRI TR, RIS PR AR
File | Edit | Window  Help
-J‘E,.- |y History

4 Undo History

Light
Ciner

Visug “ontiguration
M Editor Preferences...

e & Froject Settings...

‘l.Fqurl e Plugins

B o e SO
Edit -> iR
Plugins -> ffiff



2. fEAnimation&R%y, IS FBLive Linkfl{4 (QiiE AR FEEFE) .
U gorme

"I Analytics

B Enabled
Control Rig

Audio Framework for animation driven by user controls

Android

B Enabled ® Epic Games, Inc.

Live Link Version 2.0

Allows streaming of animated data into UE4

rofile Selectors

"i= Editor
Enabled

"= Examples

EE e h=r
Enabled -> . H

B LSS [BBNeuronLivelink &4 HE B REZJRIEES

istalled b Animation

NeuronLiveLink [EH
4 & Installed *’«
-

“iZ Mixed Reality [ Enabled Edit... Package.
4 @ Built-In

B e =r
Enabled -> &3
New! -> H¥Hr

3. ERENRGES, EUNERINPAIRERETRE.



== Content Browser

Iy AddNew~ X Import Save All & 5 | & Content »

= TS B Fites -

'h

Drop files here or right click to create content.

/| Show C++ Classes
Show Developers Content
Show Engine Content

[¥| Show Plugin Content

Show Localized Content

| Search Asset Class Names
Search Asset Path

| Search Collection Names

Thumbnails
S5cale ——
it click to create content. S
Thumbnail Edit Mode
#| Real-Time Thumbnails

™ View Options~

B A e SO

Content Browser -> P2

View Options -> 4L

Show Plugin Content -> EIR{EfFHN%E

EMEFREHLive Linkildfd, X MEHAILIBTERINIEFREHEIE (DCC) T
B, NERHEEASHIELEEZEEIVES, (REERBA LifLive Linkidft, EXEHE

{1537 UE4 FAxis StudioBUiE#E,

4. REHSR
4.1 ¥JFFAxis StudioFrEIFST {4



RIBEEBEL T Axis Studio2.4.11579.1201, S FEEARARIRIEITIEAARIEL,
BAR, 1BSEEIMAAIAxXs StudioFMERIFHRIELE,.

Axis Studio usage license

This license agreement is between you and NOITOM which is about the the Axis
Studio software license. Users must read carefully and agree to the Studio
Application License eement (hereinafter referred to as the "Licer
Agreement”) before installing and using the Studio software. Do not install
or use the Axis Studio software until you have read and agreed to the License
Agreement. If you install or use the Studio software, it means you agree to
accept this license agreement.

Authorization limit

1. You cannot perform reverse engineering, decompile, crack, change, modify, or
detect the Axis Studio software source code in any way

BJLUEIZ Axis Studio&ZIXSERTHHEERE, XA RS ERIBIRERIBVH-H1EERD
B H S Ei®: Axis Studio Version -> Axis Studio hRZAS

o FTEILZEFIF "Axis Studio”

XEARH

Rt



Best match

Axis Studio ’
L N Click Axis Studio to open the app

App L.,

Search the web . .
Axis Studio

L axis - See web results > App

Folders

Axis Studio > Open

a i

Run as administrator
Run as different user
Open file location
Pin to Start

Pin to taskbar

E ¢ ¢ 24

Uninstall

1. Type "Axis" for search
-

O axig [

B o e SO

1. Type "Axis" for search -> 1.7E48RFHI NAxisHHTHR

2. Click Axis Studio to open the app -> 2.#iiliAxis Studiolks#TJF M P

3. or You can double click the shortcut to open the app -> 3.Ei# 1RA] LLE L M diAxis
StudioffJ PRyt T X EIFR T IT N FH AR 7



New Project

FIFFFH RIS

Capturing Editing Project

Time Code
@& PN Studio
* 2.0-Cartwheel
* 2.0-Climb Stairs

Motion File

2.0-Fencing
2.0-Push Up

* 2.0-Regular Finger mavement

= 2.0-Run and Jump

* HipContact_1

* HipContact 2

& PN3

* Finger test

* Run and Jump test
2.0-Cartwheel
2.0-Climb Stairs
2.0-Fencing
2.0-Push Up
2.0-Regular Finger movement
2.0-Run and Jump
HipContact 1
HipContact_2
take028
take029
take030
test070102

B v ST 2

Open Project

Wuda-17 sensors full body-150fps

Luehan- 17 sensors full body
Wuda,Gao- 17 sensors full body
Wuda-full body with glove-100fps
Wuda-full body with glove-100fps
Wuda-17 sensors full body-150fps
Wuda-full body with glove-96fps
Wuda-full body with glove-96fps

PN3 Full Body+ Fingers, 60 fps
PN3 Full Body, 60 fps
Wuda-17 sensors full body-150fps

Luehan- 17 sensors full body
Wuda,Gao- 17 sensors full body
Wuda-full body with glove-100fps
Wuda-full body with glove-100fps
Wuda-17 sensors full body-150fps
Wuda-full body with glove-96fps
Wuda-full body with glove-96fps

1. Click "Sample Project" -> H.ii"Sample Project"
1. Double Click a file to replay, for example double click "2.0-Run and
Wt — A SCHFEAT RS, B an i "2.0-Run and Jump”
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EFHITIZEN

Single Le

" Hand

Customiz

Mew Project
Open Project
Close Project

Recent Project(s)

Settings

Workin g Ma de Introduction

License Upgrade
Update Axis Studio

About




BVH Broadcasting H - Edit

BVH Broadcasting

+" Displacement

Binary Use old header format

* UDP




Bl e D SR

Settings -> WH

1. Open Settings Menu -> 1.F]JF¥ EKH

1. Click BVH Broadcasting -> 1..idiBVHEHE E Kk

BVH Broadcasting -> BVHE 4 &

BVH-Edit -> BVH-%i%

2. Scroll to "BVH-Edit" to make it enabled -> 2.7&RFNAMEZN 2 "BVH- g "I B H (55
o A 20 2 8 RS

3. Check to Use Rotation "YXZ" and Type is "Binary" -> 3.7 3R HEHEEH "yxz" "k
T ko

Rotation -> g4

Type -> KM

Binary -> ikl

Displacement -> fif%

Use old header format -> f#i [ IH Mk

OPT -> M2

4. Use UDP anf set address and Port -> ffi FHUDPHM S I 15 B bkt Al 5
Protocol -> i

Local Address -> AcHiihht

Destination Address -> H#ritidik

Port -> ¥l

5. Click Ok to save settings -> HLiiffiE A IRIE B

oK -> i

Cancel -> HUJH

o FHEEI

chtr00
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1. Click to loop the replay -> fiiifa HEH
2. Click to Start replay -> AidiJF4fhnliK

4.2 MRfERAxis Hybrid Manager{E RN FEERECR &Lz €

{5FAxis Hybrid ManagerfFIF155% FHEAIEERF JFmocap HHEHIHEE SEIGRISISETE
L EIREER D HTIRE

o HFREEN

AXIS HYBRID MANAGER

] rh S SR
1. Click button to Open menu -> R4 4T T2 5
2. Click Preference to open dialog -> riiiPreferencef] JF 5 ifHE



o FEmpcapiit

AXIS HYBRID MANAGER

. Select Data Output Tab -> i£#Data Output

. Enable Mocap data output -> JF/3Mocap®idifith

. Select Protocol and Edit IP and port -> i&FEWH N IF44E TPHE bk Al 1
. Click OK -> s{i7OK$%4H

A W N PR
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o FIFHRAYTEAENeuron Live LinkiFHHIELITIE



File  Edit | Window | Help

1 Place Ac

- . 3 Cinematics

Search Classj _
1) Details

4y Editor Modes

Basic B® Viewports

Recently Pla

Lights 2 C:an‘.e—r- .EE-|'|E4P'.E' F'I'E"-."iE"rl'l."E'I'
= Hierarchical LOD Qutliner
Cinematic = Layers

Visual Effeci W4 Levels

| W Live Link
Geometry .

¥ Ry Place Actors
Volumes Wy statistics
AllClasses ¥ :p(:' Toolbar

v i= World Outliner

# world Settings

== Content Browser
# Developer Tools
® Find in Blueprints

B Project Launcher

e FTFFLive Link (ZCRYHEEE) &O Enable Fullscreen

B R o 0 SR
Windows -> % [
Live Link -> SZi#%ds



o TESCHYHEZE, IRIBEEIHLSERAINAXis Neuron Live)R

# Sourcelss  [7] Presets

LiveLink Sources
Hand Tracking Source Zebyielileie ~tatus
Message Bus Lirce
R . UDF Rec - 7004
9 Calact Ayis [GERF
Add Virtaat Subject TCP Address 127.0.0.1:7003
POk |

Bl D SR

Source -> J&

Presets -> Tk

1. Click Source -> Al

2. Select Axis Neuron Live -> i%£#fAxis Neuron Live
3. Setup and Click OK -> ¥ B Jf fidioK

WRFCHETRSEEATEZTRINRGER, EETHZ chro0 (REERLRIZERF
{ERIX P EFR

Role

chron Animation

B 0 SO %
Subject Name -> Xf%fr4

o ERBNEEEFFTHDemoMap(World'/NeuronLiveLink/Content/Demo/DemoMap.uMap')&
F={iIFNeuron Live Linkf&{4



== Content Browser BY output Log

DemoMap (Leve
s AddNew=" X Import Save All ¢ & Neun

PEN Search Paths §o] E| TFilter

i Content

B e h=r
Level -> xF

Path -> 1%
Cooking Filepath Length -> Mt 112K
Primary Asset Type -> T ¥/=



o EHRXNRE RT"PNS_Actor"FémiESubject name (XIRMHA)

World Outliner

Lahel

4'J4 DemoMap (Editor)

Actor

Atmospheric Fog

Cube StaticMeshActor
Floor StaticMeshActor
s Light 8 DirectionalLight

|:l [
L

-
-
“

-

]

e
-

-
|5 I':
=

-
-
r t:"f - -

-
!
I"

-
|

-
] [l
! I'_ !

-
Ll

-
W

11 actors (1 selected) @ View Options =

3 Details

. a
4 Add Component ~ & Edit Blueprint ~

Search Components

DefaultSceneRoot (Inherited)
Skeletalbesh (Inherited)

LiveLink (Inherited)

Ho
4 Transform
Location Kmszm
Rotation Kmszm
X SRS Y EEES) - EEEN
4 Default

Subject Name

4 Replication

Met Load on Client




B A e SO

World Outliner -> {HF KA

Details -> 47y

Default -> ZRik

1. Click PNS_Actor -> s iiPNS_Actor¥i sl

2. Pick a valid Subject Name -> JEHUAH ZffJSubject Name (Kl H1/&chroo)

o HRRITEVRIBERINE (Viewport FE T STRHER

Toggles real time rendering in this viewport

ow Toolbar
Stat b
reidotvien ) XIS
Far View Plane _

Screen Percentage

| Allow Cinematic Control

Game View
Immersive Mode
Allow Camera Shak
Bookmarks

Create Camera Here

High Resclution Screenshot...

Layouts

Advanced Settings...

Bl e 5 SO %

Viewport Options -> & &I

Realtime -> SEH

Toogles real time rendering in this viewport -> KL E 44 S Ve 4y
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5. SA—M R B EEMEEE

{RATLAMFBXSF RSN B ERMIBAZEIELIS 28, ASE— 19PN _Avatar.fox BISHESENE!
RE4]5|28, {ReJLAFEPluginBaseFolder/Arts/PN_Avatar foxdkZERX NS4

I AddNew » X Import Save All &

- Y - =
L

o ERENRRTRESANZH

B e SR
Add New -> i
Import -> S A
Save All -> fRAFFTH


file:///C:/Program%20Files/MarkText/resources/app.asar/dist/Arts/PN_Avatar.fbx

o EHBRNHREE NEMENFESNRIbCUGFH REEOpen

@ Import =
&« v 4 . :- .-.l o | L] Plugins » Meuronlivelink » Arts v ] £ Search Arts
Organize v Mew folder =~ [ o
_ ~
@ OneDrive PN_Avatar.fbx Date modified: 12/31/2019 415 PM
Type: 30 Dhject Size: 1.32 MB
[ This PC " !

_J 3D Objects

I Desktop 1.Select the file
@ Documents

; Downloads

J’! Music

= Pictures

m Videos

W

File name: | PN_Avatar.fbx v| All Files (*.3g2*.3gp:*.3gpp;™.3c ~

2. Click Open Cancel

B o S SO

Import -> S A

1. Select the file -> 1.#&EFE
2.Click Open -> 2. fifiopeni#fi




gl
Import Skeletal Mesh
Current Asset: /Game/F
4 Mesh
etal Mesh
Import Mesh

Import Content Type

4 Animation
Import Animations

Animation Length

4 Transform
[ Import Translation
[ Import Rot

Import Uniform Scale

4 Miscellaneous
Convert Scene
Force Fron

Convert Scene Unit

4 Material
Search Location

Material Import Method

FEX Import Options

o 1E FBXSANELR XIEEFHTIEAIIRE, (TEHRARAIE T BIRMEEILLT

o

Reset to Default

Geometry and Skinning Weights. =

None

€D

Exported Time -

b

-

Create New Materials «




Wl e D SR

FBX Import Options -> FBXS: AL
Import Skeletal Mesh -> S AE MK
Reset to Default -> HE ANERIA
Current Asset -> HFI&ST

Mesh -> Pii%{k

Skeletal Mesh -> “HHSRIFEIA

Import Mesh -> SRSk

Import Content Type -> S ANEHKAE
Skeleton -> ‘H%

Geometry and Skinning Weights -> JLfA[f&R52 i A&
Animation -> ZhiH]

Import Animations -> S AZ)iHE
Transform -> 75k

Import Translation -> S AT
Import Rotation -> S AJigh

Import Uniform Scale -> S AG—4iil
Miscellaneous -> Z%Ti

Convert Scene -> iz 5t

Force Front XAxis -> i HTXHh
Convert Scene Unit -> izt e
File Version -> X fHhA

File Creator -> fGI&#s

File Creator Application -> SCHE6IEE 2R AR
File Units -> HFHIT

File Axis Direction -> XCff4hJi A
File Frame Rate -> Cffii%
Animation Start Frame -> ZfjHitc4fMmi
Animation End Frame -> 3 45 M
Import All -> SAFTH

Import -> S A

Cancel -> HUJH

TR NRSESEES IZNEER, 5IZSNENNBBEMNEHREME— B, #
BEIRBTRA BB MIZARFREAI0Skeleton/54%,

o RE LESARBEESNZBBFBXCUFSNELSIE, TERR T MFBXSU4FSARIR
7. RERENEES LR RIFFRE (Save All) *ZHREFSARIE




== Content Browser

I AddiNew -

k= T Filters

- L] -
. SN
j
+ + - - e

M _Body

Search Content

M_Body_Dark M_FaceMask

& Import Save All

BY output Log

=

4;=

PH_Avatar.

PhysicsAsset

h_logo PH_Avatar

6. IR{ESHEEEE] (Animation Blueprint) #{r=IK
=50

o ERFENRRPAERRIIRE

PN_Ava

PN_Avatar (Skeletal Mesh)

Patl:: /Game

Cooking Filepath Length: 98 / 260
rtices: 12,589

Bones: 126

Morph Targets: 0

Triangles: 19,374

Mever Stream: i-alse

LODs: 1

urce File (Geometry and Skinnin

tal Mesh Actions
w; Create
Import LOD
Import Clothing Asset..
Skeleton
'
-
¥y Open Source Location

t

Reimport
Reimpaort With New File

Open In External Editor

/" Edit.

% Rename
% Duplicate
& Save

;

PR B BRMSIRE T Rt - > HE & - > s EEE

| Weights): E:/DEV/NeuronLiveLinkChar/Plugins/MNeuronLiveLink/Arts/PN_Avatar.fbx

M Physics Asset
Physics Asset

o scpint |

== Anim Composite

Creates an Anim Blueprint using the selected skeleton.

Blend Spaces
#: Blend Space
4" Blend Space 1D

A

Aim Offset

Ajmuiffset 10




B o e SO

1. Right Click the Skeletal Mesh -> 1.4 & #s Mk 4

1. Select Create the Anim Blueprint -> 1.i%&F61E R )5 zhHE % &
Create -> g

Anim Blueprint -> ¥ &

Anim Assets -> FJH %

o HEIEESHBIrE s Er=CIEERER B R, (R LRE TR R E ERARIANS
R, AXHEA B Emm/9BPA_PN_Avatar

FERRAGICEAM Search Content

W_Body W_Body_Dark M_FaceMask M _loga PN_fwvatar

B o e SO
1. Edit the Anim Blueprint asset name -> 1.%w%5 %] I &% 7= 1) 44

o WHEIEEE BPA_PN_AvatarkFHiadmiEnNE K E

Debug Filter

All Actions for this Blueprint

livelinkpase| r
(

4Live Link

+

ueprint Update Animation
4 Animation Graphs

Animation Layers
Functions
Macros
Variables

Event Dispatchers
name to find references.




B o e SO

1. Double click AnimGraph to enter AnimGraph -> 1.X{id;AnimGraphi] JAnimGraphz/mE &
*

2. In AnimGraph, Right Click in White Space to show the contect menu then type
"livelinkpose" to show "Live Link Pose Node" in the menu -> 2.7 % & d7AnimGrapht 1]
T AL IR A R SCSE B i N "1ivelinkpose" Kk B SZ N HERE LS (Live Link Pose) A
3. Click "Live Link Pose" to Add it to the AnimGraph -> 3. /i Scif 4k LA Hin A 3|
AnimGraph

My Blueprint -> KK

Add New -> Hzd

Graphs -> K%

EventGraph -> H/FKEE

Event Blueprint Update Animation -> ZE{} 5 [&I 5 ¥ 5 H

Animation Graphs -> zhiH &%

All Actions for this Blueprint ->Iis &I T4 #:4E

Context Sensitive -> f#¥%CHk

Live Link -> SEAfHERE

Live Link Pose -> SZHFHEHZIEH

o IERESCATHHERISR AR (Live Link Subject Name)FHZEREIRIHZES

Live Link Pose

A ke
]d Input Pose

Live Link Subject Name
chri

g 1<No Preset Selected-
ct Rale
chro0 Animation

event name to find references_.



B o e SO

1. Click Live Link Subject Name Combo box to pick a subject name -> 1.fidiLive
Link Subject NameZH & HEMLFE— X R4

2. Connect Live Link Post Output to Output Pose Result Pin -> 2.iERESZifBERELE&)
i 4 51 B2 ey L S BIResult 5

Output Pose -> M

<No Preset Selected> -> <ARikFIHEIi>

Subject -> X%

Role -> fifh

Animation -> ZhiH

o {EANeuronBlend TR —& D BERERMBEIERS —3 D BB NMERBEERITRS

PRI

Meuron Blend

':U} Input Fose

Live Link Subject Name

O Blend Weights 0 [ 1.0]

MTSEARIN TE]



T Details Asset Override Ei 1 |

Search Details E o~

4 Source Data

Live Link Subject Nan

4 Retarget
Retarget Asset MeurcnLiveLinkRemapd -~ [ S &3 5
4 Config

Blend Pose Bone Nam JESEITIS

4 Runtime

Blend Weights

HrInputPoseflIRetargetAsset f{# A 77 s\ [F LiveLinkPose i s

BlendPoseBoneName & 73 b i 7 8 R AL S AN 2 B 8% 2 FR,  BRIAE I Hips #Head B % 5%
Hipsi) N — &%

BlendWeights M IIA # AL 4% 2 AL E

1.2.06h 2 [SIRMLIt T s BRIt T mBTEEAxisStudioR B RIXNFBEE
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BARE S

S ZANNeuronLiveLinkRemapAsset

Current e Contro/ Modes Content Marketplace Settings Blueprints Cinematics Build Cq

’ Add Feature or Content Pack.. - E] EU i

A New Folder Ereciey

Interf

I AddNew'~" & Import [L >ave Al

= m_ [E] TFilters ~ [EETREIREE

L
[
> gm C++ Classes
i NeuronLiveLink Content
. Ma
i PNS
> g NeuronLiveLink C++ Classes

KRR

Blueprints are special assets that provide an intuitive, node-based interface that can be used to create new types of Actors
and script level events; giving designers and gameplay programmers the tools to quickly create and iterate gameplay from
within Unreal Editor without ever needing to write a line of code.

vonent »

ad | [
o | |
BPAPN. !

10 items

1. Click Add New -> 1.7
2. Select Blueprint->Blueprint Class to Add a new Blueprint -> 2.3&##5 K-> KRG

I —7 ] Bt
Bluepirnt -> ¥ [&
Blueprint Class -> {2

Blueprint Function Library -> ¥ %%
Blueprint Interface -> WM
Blueprint Macro Library -> K%

Enumeration -> #%¢
Structure -> iy



Pick Parent Class
4 Common Classes

An Actor is an object that can be placed or spawned in the
0 Actor world. ; J F *

A Pawn is an actor that can be "possessed’ and receive

& Pawn input from a controller.

A character is a type of Pawn that includes the ability to

. Character walk around.

A Player Controller is an actor responsible for controlling a

% Player Controller Pawn used by the player.

Game Mode Base defines the game being played, its rules,
fw] Game Mode Base scoring, and other facets of the game type.

An ActorComponent is a reusable component that can be

iehaClELCamponsat added to any actor.

Seena Component A Scene Component is a component that has a scene
“ P transform and can be attached to other scene components.
4 All Clezzes

Neuron <— 2. DE nNeuron 1o 1iter CIasses

GamemModeBase
™4 MeuronLiveLink restGameModesase
40 LiveLinkRetargetAsset

7 items (1 selected) Meuron Live Link Remap Asset o« View Options~

Select Cancel

B o e SO

1. Click "All Classes" -> 1.pfidi"fTEk"

2. Type "neuron" to filter classes -> 2.## A\ "neuron"KiljE
3. Choose NeuronLivelLinkRemapAsset as Parent -> 3. NeuronLivelLinkRemapAsset{E N
KK

4. Click "Select" to Create BP -> 4. /""" 621
Pick Parent Class -> EH(R%E

Common Classes -> i W.2&

All Classes -> fTf2%

7 items(1 selected) -> 73 (1Tiikr)

View Options -> #fE#ET

Select -> i&F

Cancel -> HUH



BESENSSETOE, (REILUFE RS PN Avatar RemapAsset S EIEHR

AN CER M Search Content

M _Bodyy I_Body

o REIZNEEEwEeR (SR ES(Live Link Pose)*ﬁ,mE’Jretarget asset

= AnimGraph

4 Source Data

Live Link Subject Nan

4 Retarget

Reta @ PN_Avatar_RemapAsset = [N O N]

Output Pose

Live Link Pose ’M\’

B o e SO

1. In AnimGraph Click Live Link Pose Node -> 1./idiAnimGraph b (i) s i 4 2 8 2577
2. In Details Panel, Select the new blueprint asset(PN_Avatar_remapAsset) as
Retarget Asset -> 7E4H5 ML B 6 2 1 i B 55 7 (LA 812 IPN_Avatar_remapAsset i /”)
{E NRetarget Asset

Details -> 4077

Preview Scene Sett -> Tl E

Anim Preview Ed1tor -> B T o R A

Asset Browser -> /73 NE

o (RIFDNEIEE], T—2F(11EmIEPN_Avatar_RemapAssetif{TE B8 AFRERET

7. EIRGIEERATN



{RRYBEERIIBIATI LAERSAXiIsSSEEA RN B IR ETR. IR BEER(FH
NeuronLiveLinkRemapAsset {EI{RAYSCAT$EZESAY Retarget Asset, {RBEN{RIVEERCIER
CHIRetarget Asset, ATIIGLKEE Retarget AssetfIEFITIE, 1 E—Ep0 HREIEIE
(Animation Blueprint) ZRF=IKaNEE8](6. R{ENEIIEE] (Animation Blueprint) HR=IKzIEE)
IS K67 T IEE|PN_Avatar_RemapAsset 512 N TISFHARIEDS

HANERBERRTR



Hips = ©
RightUpLeg
RightLeg
RightFoot
LeftUplLeg
LeftLeg

LeftFoot

Spine

Spinel

Spine2

Neck

Neck1l

Head
RightShoulder
RightArm
RightForeArm
RightHand
RightHandThumbl
RightHandThumb2
RightHandThumb3
RightInHandIndex
RightHandIndex1
RightHandIndex2
RightHandIndex3
RightInHandMiddle
RightHandMiddlel
RightHandMiddle2
RightHandMiddle3
RightInHandRing
RightHandRingl
RightHandRing2
RightHandRing3
RightInHandPinky
RightHandPinky1l
RightHandPinky2
RightHandPinky3
LeftShoulder
LeftArm
LeftForeArm
LeftHand
LeftHandThumbl
LeftHandThumb2
LeftHandThumb3
LeftInHandIndex
LeftHandIndex1
LeftHandIndex2
LeftHandIndex3
LeftInHandMiddle
LeftHandMiddlel
LeftHandMiddle2



LeftHandMiddle3,
LeftInHandRing,
LeftHandRingl,
LeftHandRing2,
LeftHandRing3,
LeftInHandPinky,
LeftHandPinky1,
LeftHandPinky2,
LeftHandPinky3,
Spine3,

Axis Neuron {FAHipsSpineSpine3,NeckHeadLeftHandPinky3{E 9B B8R FR, Neck 1>R{EF
Axis Studio {Hips~LeftHandPinky3{EAB8&&FR, Spine3k{EH
7.1 (EREEPEMRGI EERRR

o ERBNINZEZEXWEHPN_Avatar_RemapAsseti JH B RIEE8F ffa{REnable BoneMapping
BiGRSKRBE 2 - 3 R B iR R TR E ST

to add some, Open Full Blueprint Editer

2 mas



B o e SO

1. Make sure "Enable BoneMapping" is checked -> 1. Hi{fEnable BoneMapping#& /AR
2. check the box to edit Mapping for this bone -> 2. /&Ji% 1 % 4 FR Al 1) 3% FHE K I 46 9
X PR T ) B AR

3. Modify the Mapped Name or Import a Skeleton and select bones -> 3.7ECAHEH B B
B S () B AR B RN — B IR B AR I A AR

Parent Class -> K

Compile -> ZWi¥

Save -> fRAF
Browse -> ¥

Class Defaults -> ZBERINH

NOTE: This is a data only blueprint, so only the default values are shown, It does
not have any script or variables, If you want to add some Open Full Blueprint
Editor -> WHE: RXE-NAKEER, AR ERBIME. BEAUSEMEASREE, WRE
BN, AT T w0 ] g AR AR

Search Details -> &G

o SABRATERY
5 - iii uﬂ

(None)




Pick Bone Mapping To...

Mo ||T| ]

Moito

MNoito H#IH.HHH
Moitom htFareArm
MNoito nt
Mo htHand
htHandThumb
h htHand Thumb2
MNoito ”Hﬂ“”Th”nh_
Moitom_

Alrnd

Armo [

Moito htinHandIn
MNoito tinHandin
Mortom_Righ
Moito
MNoito nt
tinHandh
Armo tinHandind
Armior tinHandind
MNoito htlnHand
MNoito nt

MNoitom htlnHand
Moito 1

MNoito

Armo

ﬁ.rn‘.l:l

HHHHH.HHMHHHaHHHHm

B e SR

1. Scroll to the end and click "Pick a skeleton" -> 1.7&shF| W F 5 Adi"Pick a
skeleton"

2. Select the skeleton you want to map to, then click it -> 2. EFREEWLSAH B IF A
e

1. Pick a skeleton will add bones in the skeleton to the list -> 1. "Pick a

skeleton" 2 & 8% B B A & 3k I 251 %
2. Click Select -> 2.#iiiSelect
3. You can type a name to search form the list -> 3. ilid#i N\ &R LATE SR HiEiT

=
4, Click the skeleton will modify the mapped name with the skeleton you select ->

4. FTRE G A PRORE 2 K IR 1 B AL AR SO R R

o IRIBELEIREIR



s Noftom.
™ f

Skeleton /Game/PN_Avatar_Skeleton. PN_Avatar_Skeleton
Pick a skeleton

Bone Name Prefix

4 Axis Neuron Live Link Retarget

P e e SO %

1. Bone name Prefix Can add a prefix to each mapped bone, you can type less words
-> 1. HKRAWATL (Bone name Prefix) W] AR BB A & Skds n— > 3 5] 1 T Sk 08/
R

2. After you type enter, the prefix will be updated -> 2.3 AFRIZE)G, BIEKAHR ST
¥

o “@igUseDisplacementDat

le3

ans
5

T r—

Skeleton /Game/PN_Avatar_Skeleton. PN_Avatar_Skeleton
Pick a skeleton

Bon
Axis Neuron Live Link Retarget

Us ment Data

P e e SO %
1. Use Displacement Data indicate whether you use the replacement data or not in
remapping -> 1.Use Displacement Data# /m{RfEEHLTIS, &M HABEAE (WA KIS

o WNREHAIFAZRSAZET-Pose, (REJLURAT-PoseBIzhiE 77 EI N E IS ERYSCRT sk 2 2R
Input Pose5 |f)

Output Pose

Play PN_Avatar_Anim Live Link Pose




Py rp S SO %
1. Drag the TPose Anim to animGraph -> 1.¥TPosefI3}H FF 414G %] AnimGraph
2. Connect the output with Live Link Pose Input Pose Pin -> 2.7 iz r%mH 5l

JiH1 5 SE R B 2 A F ) Input Pose 5| il

s

LA RS AN G ETPoses B, FIFHRERINBIRE, BELHNE
BHeE T-pose RIS HRINEBRFEI— N EIEFS!
p—

Search Skeleton
o Cre
v

-3~ Noitom_Hips
-} Noitom_LeftUpLeg
-}~ Noitom_LeftLeg
4-$- Noitom_LeftFoot
4-%- Noitom_LeftFoot_End
¥~ LiftFoot_Toe
$- Armor_LeftFoot
{- Armor_Leg_Left
' Armor_UpperLeg_Left
-} Noitom_RightUpLeg
-}~ Noitom_RightLeg
4-$- Noitom_RightFoot
4-}- Noitom_RightFoot_End
1- RightFoot_Toe
4 Armor_RightFoot
{- Armor_Leg_Right
- Armor_UpperLeg_Right

4-§- Noitom_Spine

4-}- Noitom_Spine2
4-%- Noitom_Right Shoulder
4-%- Noitom_RightArm
4~ Noitom_RightArm_Roll
¢~ Noitom_RightForeArm

{- Noitom_RightForeArm_Roll

4-}- Noitom_RightHand
4-}- Noitom_RightHandThumb1

htHandThumb3
andThumb_End
- Armor_RightHandThumb3
- Armor_RightHandThumb1
4-}- Noitom_RightInHandindex
4-§- Noitom_RightinHandindex1
a4 Nonom RightinHandindex2

InHandindex_End
ghtinHandindex3
+4- Armor_RightinHandindex2
$- Armor_RightInHandIndex1
4-}- Noitom_RightInHandMiddle
4l Nnilom_RighlInHandMiddIe]

B EESCENE: Create Asset -> BlJZE#RT= Create Animation -> BIZEENHE Reference
Pose -> SEZ# Current Pose -> HpI&

7.2 B BRI T R ARG

BAWEARER L AN EHTEIREMREY, SNR(REX S IR — L EENISRIEE, (RaJLL
E8# NeuronLiveLinkRemapAsset IEEF Y GetRemappedBoneName FREEEHRAIAE L, TEEE

ERE 2 BB SRR B )ik "Enable BoneMapping "



8 Details "Iz Palette

Search Details

4 Axis Neuron Bone Mapping
Enahle BoneMapping
0

TE2EAEDS RIS R FIERFR
" InHand "B} /55%

7.3 MLiveLinkRetargetAssetSERkF kiR E CHEERES

MERRRNERFARE, (REJLAMC++ZELiveLinkRetargetAssetiH{ T FHEHIEERNTEE
8, #MEIHEEFAINeuronLivelinkRemapAssetZE—#£,

8 {ELiveLinkiZHlZEZH{%¥LiveLink Controller
Componentizfhea A

XZLivelinkBHRIEARFEEL, BT AS%E Unreal 75 3 (EALiveLink&UEER
https://docs.unrealengine.com/4.27/zh-
CN/AnimatingObjects/SkeletalMeshAnimation/LiveLinkPlugin/LiveLinkBlueprintComponent/, %[l
HHEHBWETransform A BRIEHER Bl LIFEIRshER 7

9. [Axis Studio&ZIEIEHIIES



https://docs.unrealengine.com/4.27/zh-CN/AnimatingObjects/SkeletalMeshAnimation/LiveLinkPlugin/LiveLinkBlueprintComponent/%EF%BC%8C%E5%A6%82%E8%BF%87%E6%8F%92%E4%BB%B6%E6%9C%89%E6%94%B6%E5%88%B0Transform%E8%A7%92%E8%89%B2%E7%9A%84%E6%95%B0%E6%8D%AE%E5%B0%B1%E5%8F%AF%E4%BB%A5%E7%94%A8%E5%AE%83%E9%A9%B1%E5%8A%A8%E9%81%93%E5%85%B7%E4%BA%86

1 2OGH&ZME#I?T&?JDT_JLXF]AXIsStud|07i1_—‘“4? SHFESAITNRE, AP AL EUnreal Editorali&
FTRERITHBISUGFEAXs StudioKIXIEHIFES

9.1 ZHFHTES
/LR
ViTEE:S
RERTERE
IREIEED

H RHEHTIRIRENAxis StudiofIRHBPAZ, FEZINTEAXs Studiofb T REVASEHIHEREIEABITR
HHTIE S RIEEIF.

{EFUDPIRIUHITIEBIERT, 3K (Axis StudioBkAHM) HIBETRIP HBIEAER (R
255.255.255.255

v1.2 20h AN FAR TS SR A LAB OISR BISLA-RTR AxisStudio e B & (£ FIR BRI (2R

9.2 (EfmiE=EP(EH

o X ~IRIERT T Ei=FmENeuront®fl (FEIPI1ATR) SEBEORKE=HAINeuronSERIN
(TIEPZFET)ﬂHjNeuron? Zi)iilil _

Bring up NeuronEditorWindow window

FIFFRIEDOT



U

AXIS STUDIO

NedTon

CurrentLiveLinkSource:

I (!

File Name

Connection Status:

TESCATSEEE O, % 0NAxis Neuroni&
BOSBEaNkFEEZRIAxs Neuronf, BEFES N IRINHEEERERTIESKIERIR

Neuroni§<$ & iEB 9 Connection StatusIO0nlinelf#t ] LUBIT B O PRYiLHE Axis RiETS

PAN
>

AEXRmiEsE TR~ mENeurontZl (FEIR1ATR) BEEORE=ZHAINeuronSZERIR
(FES 2R EHNeuronigs S RIEE
m _

= WBFP_A

Help

z. M5 B

Settings Elueprints Cinematics Build
Recently Pla

Sa Cori place y
Basic THEea B BCERED -
ights

o
Visual Effect

Geometry
Volumes

All Classes

Bring up NeuronEditorwindow window

Level: CommandTestMap (Persistent)

FIFNELOWT



gl

AXIS STUDIC

Nenron

CurrentLiveLinkSource:

I (]

File Name

Connection Status:

TESCAYSEEE O, imI0Axis Neuron)&
BOSBahEEEREAxs Neuron®, (BEFES NRNEEEEFEEHITIES KENIR
NeuronfE< &iEE 9 Connection StatusAOnlineBd T ] LUBITE O PHYiZsHA Axis &1%ETS

PN
<

X RRiEE T Ei=FmEENeuronizi] (FEIF 1) & BEASE=FHINeuronZERIR
('FIEPZFET)U?H:.'Neuron?E IXEE

4] LiveLink # Plugine 2= WEBPLAXisstudin

w
wm B 83 =
»
»

1 © Ao <8 v [a&] ] WEB

L

Bring up NeuronEditorwindow window

Level: CommandTestMap (Persistent)

FIFREOW T



gl

AXIS STUDIC

Nenron

CurrentLiveLinkSource:

I (]

File Name

Connection Status:

o TESCHYHEIZEE, imINAxis Neuron)&
o BOSBEFEEAAXs Neuron]], (BEEFEZNRNBSEISFERTIESKIER
e Neuronfg<$ & 1EE 9 Connection StatusAOnlineRfFt A LUBIT & O PaYIZHA Axis RiETS

PN
5

9.3 EiETTHIfER

WRBEE TR EF T BEMAAXsStudioKIEIES, ATLUSHREFRIWBP_AxisStudioUlController
IEEActoRIXR=H, X MActorfEBa12BatIEiE<S &£V

== Content Browser B Output Log WBP_AxisStudioUlController (Blueprint Class)
I AddNew'» & Import Save All & - | & NeuronLiveLink Content » Mot

In |I'|I
Parent Class: Actor
Native Parer 55 Actor

- Blueprint Ty rmal

Blueprint €

>em NeuronLiveLink C++ Classes R




FTCRREERIEITH, IEHERWBP_AxisStudiofZ 415 [EJAxis StudioRIXIE<S

- Plane

i 45h

¥ Box Trigger

- Sphere Trigger WBP_AxisStudio (widget Blueprint)

[MeuronLivelink/ M
LIMG.

Normal
False
== Content Browser B} output Log
Auto
e AddNew ~ X Import Save All & & NeuronLiveLink Conf 0
Latent

U E&m C++ Classes i Sl
26

4 @ NeuronLiveLink Content Default
emaping False

b gm NeuronLiveLink C++ Classes LT SRR

G TR ERINAIN T BN FHEIZ T BE BT 6U## Axis Neuron Livejg,



AXIS STUDIO

CurrentLiveLinkSource:

:1:: 'i' |H|

File Mame

Protocol
TCP
Server Address

I[P 127.0.0.1 Port | 7003

Client Port

FJ o rt TE‘ |:'-'-1-

Connect New Live Link Source

Disconnect Current Live Link Source

Connection Status:

xR AT LASE 134z HaILIl B SsLUIME AxisStudio RIXTES

é’ﬂ_ YRiESEENeuronig$ ZiL/I\EH:Tﬁ—'FH__I' BT R REEFI AR R TIRIE, &1
T FFEEIXANeuroniES AIXE .

9.4 FIREEZS A FHITER

B MIEINS N ERrE AR EREZS MR TIEEE. J:?‘_I%,L,\‘JZ%H@EF%—/PFEI
LUBISFEXEHRINZ N\ WBP_AxisStudioUlControllenZEEARRRIRSH Tisdl, WATEILUBIT &
ActorEl’JW|dgetScreenPosmomeﬁET_ FEENAE



= World Outliner

Search...
La |:| E'l T':'rlj e
* CameraActor CameraActo
i Floor StaticMeshAct
# | ight Source DirectionalLight
Player Start Plaver
FMNFProp Edi

Sky Sphere

Light SkyLi |||'
# SphereReflectionCapture SphereReflectionCa

) WBP_AxisStudioUIColtroller Edit WEP_Amet :

15 actors (1 selected) > View Options~

-
Ll

-
W

-
L

-
L

-
W

"
§ -

-
Ll

-
W

3 Details @ viorld Settings

[ W WEP_AxisStudioUICaltroller M

4 Add Component ~ o2 Edit Blueprint ~

Search Components
( WBP_AxisStudioUIColtroller(self)

DefaultSceneRoot (Inherited)

[SeachDetails ol = [
4 Transform

Locaton + x S VS 2 TS
Aotaion + « (TS VTS 2 TS
Scale = x S V) S

4 Default
> wisget Sereen position XS] CACTIN)

4 Rendering
Actor Hidden In Game .
Editor Billboard Sc

4 Replication

Met Load on Client

10. TE160
10.1 (25 RIS BRI SER:E A E LR E)



o EEXTEH#FE B gclick the **15E] (Blueprints) IEAFFEIFFIFF A FIEE (Open Level
Blueprint)**

BRI

Save Current  Source Control Content Marketplace Settings Blueprir Cinematics Build
Blueprin 55
Mew Empty Blueprint Class...

g Open Blueprint Class...

Viode: Not overridden!

TR EEHEZR(Event Graph) £RREVANEHEFIRIETT(Event BeginPlay) and 554§
Tick(Event Tick).

File Edit View Debug Window Help

M 1y Bluepri y@ ) - @ n _%.‘ . f" ’ M ’

=+ Add New ~ )
Compile Save Eruw e Find  Hide Unrelated la ngs  Class Defaults Play

4Graphs

423 EventGraph
© Event BeginPlay
<> Event Tick
Functions (1
Macros

Variables

Event Dispatchers

o II—MEHISERT R (Live Link)— N2



o ISEFMESTETNE +* #&4H, A +*+ 8 (+ Variable) RIS EERFHIIE L E,
M 1y Blueprint

+ Add New ~ o~

4Graphs +

4m: EventGraph

<> Event BeginPlay
> Event Tick
Functions
Macros
4Variables

Event Dispatchers +

FEETERZ [EAMBERE SLivelinkHandleFHE T EIZE#

3 Details

Search Details jo E o~

4 Variable
(EUENERTET LiveLinkHandle | |

Instance Edi [Jj
Blueprint Re [
soltip

Expose to Ci
Category Default
Replication

Replication |

4 Default Value

Please compile the blueprint




o FEMTEIRZIGIRETEZLT (Variable Type) BEEHT (Structure) LiveLinkiB&ME (Live
3 Details
Search Details jo E
4 Variable
Variable Name click. X1
variabie Type - [T g

[Live link source | [_Z_x search Live Link source

4 Structure
Live Link Source 3 . select thiz one
4 Object Types
| Take Recorder Live Link Source

Link Source Handle)

B b S SR

Variable -> &&=

Variable Name -> ZFE 4

Variable Type -> ZZ&2KH

Search Live Link source -> #ZLive Link source

Structure -> i
Live Link Source Handle -> Live LinkyfAb3¥

o TEE{HEIER(Event Graph)F 8l Neuron Live Link Source at runtimes S SBHEFHRIZIT
(Event BeginPlay)** &z

o i iNCreate Neuron Live Link Source at runtimeT RH-5**H{4FF8I=1T(Event
BeginPlay)**1&#z



m= Event Graph

W

> Event BeginPlay Drag out

[ —
Executable actions Context Sensitive

[ Get Livé Link Subject Role
[ Get Livé Link Subjects
[ Get Source Machine Name
[ Get Source Status
[ Get Source Type
[ Get specific Ll Link Subject Role
[ 1s source still valid
f Remove Source

< Meuron Live Link 3 Select Create Neuron Live Link
r Live

A Utinies

4 Casting

=+ Cast To LiveLinkAnimationAxisSwitchPreProcessor
=+ Cast To LiveLinkAnimationAxisSwitchPreProcessor Clas

m= Event Graph

> Event BeginPlay | Create Neuron Live Link Source at runtime
=P P

Connection String D Handle

o fBl#LiveLinkHandlefYiZ & T mHf-5Create Neuron Live Link Source at runtimejEiz

My Blueprint ma Event Graph

shddie NS ©-

Graphs +
== EventGraph

& Event BeginPlay

& Event Tick

Macros

. - ~
Functions (1 L ¢> Event BeginPlay [ [ Create Neuron Live Link Source at runtime (1 | Drag out

o

Ytz Connection String D Handle Executable actions

LiveLinkHandle SIS H Sea'dlthe il
: dVasichles variable you add
Event Dispatchers 4 Default




m= Event Graph

> Event BeginPlay f Create Neuron Live Link Source at runtime

Connection String |_| Handle

o 1EZFECreate Neuron Live Link Source at runtimefiConnection String3 | FJFFSCRTHEE
(Live Link &N

u ) L

4 Sourcels. ] Preseis~

Source Type  Source Machir Status Search Details
4 Settings
Evaluation Mode Engine Time -

Subject Name Raole
4 Buffer - Settings
chro0 Animation
Max Mumber Of Fram Qiy

lid Buffer

4 Debug

urce Debug Infos

0 Error(s) 0 Warning(s) Clear

E1E Axis StudiojFHRHREERIEREHEIN(Show Advanced)gisk (A1 TFEAH2FT
)



U B Lz s '

4 Sourcelw 5] Presetsw

achin Stat Search Details

UDP//0.0.0.07Running &0 |4 Settings
Evaluation Mode

ect Name Role v g

4 Buffer - Settings Show Advanced
chroo Animation

Max Number Of Fram
: e —
-

4 Debug

e Debug Infos

0 Warnir Clear

k=788 (Connect string)FFactory{GEHEIR P B7RH¥E

u 1) Cvein
4 Source/w 7] Presets=
Sourc 2 Source Machir Status D~
4 Settings
Evaluation Mode (1 : copy connetion String

String 0.0.0.0:7002, 1, 192.168.8.249: 7986 [l

chron Animation a / Class'/Script/NeuronLivi o

jject Mame Role

b

4 Buffer - Settings

Max NMumber IZ:lr'Frnrr'

lid Buffer 1.0s I\

0 Warning(s) Clear

FEHEHZEF1TER (Connection String)AYEFE IR FHRENEZIX - RIGEIRTEIEZRAICreate



Neuron Live Link Source at runtimeT5 s&2JConnection String5 |

m= Event Graph

1<

> Event BeginPlay [ create Neuron Live Link Source at runtime

a
»P—"> » »
Connection String Handle
0.0.0.0:7002,1,7921 58.8.249:?9-‘36|

Live Link Handle

o BMRlive link JEAMBEIFH S5 F4255RIE1T(Event EndPlay)** 5 mfEiE
o GREAETHLETLILIE SHERIEIT(Event EndPlay).

m= Event Graph

ykg ma Untitled > Event Graph

All Actions for this Blueprint Context Sensitive
event end play

A pAdd Event

€ Event End Play
4 Game

—
SZ

o Bl#ERemove SourceTI mFHiZEE

Executable actions Context Sensitive

End Play Reason
IR M2 Search Remove source

4 Audio
4Effects
[ Remove Solirce Effect from Preset Chain
4Live Link
/" Remove Source 3 . Select this one
4Take Recorder
j Remove Actor from S




o fl&ELiveLinkHandlefY3kEY T = 5Remove SourceT =8i&E

vent Graph

Actions providing a(n) Live Link So
Handle Structure (by ref)
I 2 X Search get
4Hand Tracking
4 Magic Leap
f Get
AUtilities
- Array

4V ariables
A Default
e o R BetLive Link Handle
> Event End Play f Remove Source Ve S Randie
3 Select the variable you add

End Flay Reason < Source Handle Return Value

L IR \

e The event graph will show like the following image, Click Compile and Save the level
blueprint

B BHEEN FEFTT, SEHE Compile)FHRR(Save) X KI5 E
(W2 s S # ¥ P .z

Compile {1 Savel2 Browse ind  Hide Unrelated cla Class Defaults HEN Debug Filter

M My Blueprint

+AddNew - EETINIES) © -

¢ Event BeginPlay [ Create Neuron Live Link Source at runtime

Functions nectio g Handle Live Link Handle

SET

Macros
4Variables
LiveLinkHandle

Event Dispatchers

< Event End Play - Remove Source
b P (2

End Play Reason Source Handle Return Value

—_—

“ Live Link Handle

10.2 fEXRHIE B BRI (Skeletal Mesh)FHgETIEIEE

(animation blueprint)



T NAEIERR(Content Browsen)** /i, EUEHRERNZIR - RHRIBERIBIAZ = FHIGEIFN
Skeletal Mesh ActoriFINEIX-RHRHIU TEIRIECHINESE (Anim Class) . ARMAIREIET
(Play) B FMITRAIZIERIER. MR—INETIER AR 7 IRMFHRIIR R EFIE s



= World Outliner

FY

|_ a |'I F'l T':!rlj g
T 44 Untitled (Editor) Worle
= Atmospheric Fog

H' Flofh  select your character
5.5 L|||||T 5

:-

B actors (1 selected) @ View Options =

T Details @ World Settings

" Model_PN_Studio_LUE4

L N e e
e LU IR AT L] PR LS T A

4 Animation

LI EuBa GGl Lise Animation Blueprint +
poimcocs (S

Disable Post Fz" click dropdown menu

4 Animation

Animation Mode Use Animation Blueprint +
Anim Class Model_PM_PN_Pro_UE4_Skeleton_Aniv el

Model_PN_Studio_UE4_Skeleton_AnimBlueprint (Animation Blueprint)

fGame/Animation
145 f 260
Animinstance
Animinstance
Mormal
False

IR R LB S E R E B iR RIR - RROM O 2iE B E R JRIPNS _ActoriEEISE
RIRERIRE CRIS M IZI B ERIRE(RRIZIERE



10.3 12 EF K EIAMEE] (Game Default map)

EFTEIPR 2B, (RELEEREIEEIAE (Game Default Map), iIXakittESEF T BEHIHRE
AN, WMRRENAIES TEHEIREIREE, MTEHENEEEREERIER, W
RIRE R EERIEI LA S — AFRENR (First-Person template) & & 55 = AFRENR(Third Person
template), IEIRAVFIIAHEEIE S INE

o RifmiEsEERPRVRIE->INEIRE - > EFIUEU (Edit > Project Settings > Maps &

File | Edit "-jl"i ndow  Help

R n History
#7) Undo Clicking on Actors
5

Rece o# Cut

Basic ' Copy

M Undo Histo ry

Lo 2w Duplicate

Ciner 4 Delete

nfiguration
A Editor Preferences. ..

[ P s

Volur # Plugins

Visuz -

Search Details

4Project - Maps & Modes

'h These settings are saved in DefaultEngine.ini, which is currently writable.

4 Default Modes

Default GameMode GameModeBase Ll = O 4

[» Selected GameMode

4 Default Maps

l " PackageBP
Editor Startup Maop ERRY

1 Select the level you just saved.

i S _ b ‘ PackageBP
EI1g|I1e Game Default Map '.'.‘:\‘ * D

Al System



I RERFERERE(RE CRUF R I(game mode)KERIRE ChIITR A&t
AR

10.4 BRRN TEFT R AIRITRIZHERER

ERtERS R BRIEEU - >F T BINE - > (FARRX TR TTE (B 115%E T Windows 64-
bit SE&)

File ":l"l it Window Hel P

Load and“ave .
A Mew Level... E * =

B Open Level... Save Current  Source Control

Save Current

D

ctor
e Files to Save... I
Connect To Source Control...
‘Toject
- .
B Mew Project...
™ Open Project... jht

W New C++ Class...
m W  Android
HoloLens
Cook Content for Windows g i0S
Linux
# Validate Data... @  Lumin
P — g ftvOs
Impaort Into Level... l m Windows (32-bit)
Export All... Zip Up Project l

Export Selected... C . 4
Build Configuration r= Content » Anir

Favorite Levels . :
Labis Packaging Se

r@. Recent Levels Supported

%5 Recent Projects

] Exit

—MEEERERINEESSEE, FJEREXTERSE ST I8RNIE

1. #EFES



|  NeuronLiveLink.uplugin AR SCFPLugin description file

|  BuildInfo A FE A K 235 B fFBasic Build info for plugin

+---Arts

| Mannequin_Tpose.FBX ffiffHf FI FJUE4BK A & B8 45 fMannequinf¥ TPoses)jE] UE4 default
Mannequin Tpose animation FBX

| SK_Mannequin.FBX i 1F A A FH R UEA BRI 15 5% 45 #JMannequin UE4 default Mannequin
skeletal mesh

| Mixamo_Ch46_nonPBR.fbx #fiffH ffIMixamo Ch46zl7& M ASKFBXHE = Mixamo Ch46 model
in FBX format

| PN_Avatar.fbx AR SN B4 5] % FBXSC/FFBX File for import skeletal
animation to unreal engine

| PN_Avatar_Stickman@l.fbx fdiffrh 2 (i ERIA & B S5 1 FBXSCHF Plugin default
skeletal mesh

|

+---Binaries

|  \---Wine4 PR 3t S EBinaries files of the plugin

|

+---Content

| | BP_PNSBaseActor.uasset UXZhAxis Studio® #% M & 1A K ActorfJiBase actor for
driving skeletal mesh animation in Axis Studio

| | PNS_Prop.uasset IX5)Axis Studioif HffJActorZéActor for driving props in Axis

Studio

|

|  +---Maps

| | DemoMap . umap R R KR KIDemo map for use the plugin

| DemoMap_BuiltData.uasset i P 4 0 Pl ) S 4 v M K Build data for map

| | CommandTestMap.umap AxisStudiofg &Mk & Axis Studio Command test map
| CommandTestMap_BuiltData.uasset i 4 00 K e P (1 T P ) e B V3 ) 2R Buii 1l
data for map

|

I

|  +---Mannequin SR AL UEABR A H B% 45 MIMannequin & B& A AR . B WG FE . )i 5
K. B S L ActorXt % Mannequin skeletal mesh, materials, textures, animation
blueprint, remap asset and actor object in UE4

|

|  +---Mixamo_Ch46 J@ifF$EfiiMixamo ch461) & B MR, BB WHE . 2 s Rl . 3w 8t 7 &
ActorXf % Mixamo ch46 skeletal mesh, materials, textures, animation blueprint, remap
asset and actor object

.

|  +---MocapCommandUI Axis Studio F§4 Kkt

|

| \---PNSChar JffF#R LB\ B B WA (A, AT WG, BhE g R BB 55 K ActorXf &
default skeletal mesh, materials, textures, animation blueprint, remap asset and actor
object

|

+---Doc

| AxisUnreallivelLinkPlugin Handbook_EN.pdf ARFMILRAThis handbook in
English language version

| AxisUnreallivelLinkPlugin Handbook_CN.pdf AFM A LA This handbook in
Chinese language version



+---Intermediate  fHAFAIHAISCAE CAE RO Sk SCAFRI P 36 H AR SCAF5S) Intermediate
fies(generated header files, precompiled object files etc.) for the plugin
|
+---Resources
| Icon128.png B rIcon files for plugin
| ButtonIcon_40x.png NeuroniZ 4l E b
|
\---Source RS sources files for Plugin

+---NeuronLivelLink Fftneuron (mocapApi) #i#E fiLive linkiZ{THfftLive link runtime
module for neuron(mocapApi)

| | NeuronLivelLink.Build.cs PR 3 FModule build file
|
+---Private
| AnimNode_NeuronBlend.cpp
| MocapApilog.cpp
| MocapAppManager. cpp
| MocapClient.cpp
| MocapStructs.cpp
| NeuronLivelLink.cpp
| NeuronlLivelLinkBPLibrary.cpp
| NeuronlLivelLinkLog.cpp
| NeuronLivelLinkRemapAsset.cpp
| NeuronLivelinkSource.cpp
| NeuronLivelLinkSourceFactory.cpp
| NeuronVPVolume.cpp
| PNSAnimInstance.cpp
| SNeuronLivelLinkSourceFactory.cpp
| SubjectNameSetter.cpp
|
\

---Public
AnimNode NeuronBlend.h NeuronBlends) i 75 5 NeuronBlend animation node
MocapApilog.h Wit H &K Log category used in this module
MocapAppManager.h HiHtMocap N FH & P 2EMocap application manager
| MocapClient.h TE SR IE R i ltaxis studioZiHf fIMocap 7 iiiMocapClient
for receiving axis studio data in live link
| MocapStructs.h TP MocapXt i Z) T 45 fStruct used in unreal engine
for MocapApi
| NeuronBoneMappingInfo.h FH 55 52 [ R 8% 54 S Bone mapping info for
retargeting
| NeuronLivelLink.h WHLHE [Module interface file
| NeuronLivelLinkBPLibrary.h W B %% Blueprint library
| NeuronLivelLinkLog.h it H &3 Log category used in this module
| NeuronLivelLinkRemapAsset.h IR B 2y 1) B4 vk N FE 5 [F) 55 77 25Retargrting
asset for dirving animation data

| NeuronLivelLinkSource.h NeuronfJSZif 45 Live 1ink source for neuron
| NeuronLivelLinkSourceFactory.h Al NeuronLivelLinkSourcef) T.) 2§

Factory for create NeuronLivelinkSource

| PNSAnimInstance.h W BB e 2E (AT E X B4 ) Blueprint amimation
instance(can set subject name) for diving animation data

| SNeuronLivelinkSourceFactory.h Bl NeuronLivelLinkSourceff 45 # UT 4
ffEditor UI for create NeuronlLivelinkSource



| SubjectNameSetter.h FH 115 2 m 5 B A5 B % 44 (Subject name) )15 B 4%
Subject name setter for animation blueprint
I
\---ThirdParty
+---MocapApi i+ Maxis studiofZWiiMocapApi C++ZEexteral MocapApi C++ lib to
receive data form axis studio
|  +---bin MocapApi il FEMocapApiC++ 1ib binary files
[ +---doc MocapApi X f4MocapApi dociument
|  \---include
[ MocapApi.h MocapApi C++ lib header file
|

+---NeuronGraphNode NeuronBlendsf) i % P AT MLAL 5 p
| AnimGraphNode_NeuronBlend.cpp
| AnimGraphNode_NeuronBlend.h NeuronBlend Graphi fiNeuronBlend
animation graph node
| NeuronGraphNode.Build.cs Module build file
| NeuronGraphNodeModule.cpp
|
\---NeuronLivelLinkEditor Neuron Live Link#w#H#$+H %A% tNeuron Live Link
Editor module
|  NeuronLivelLinkEditor.Build.cs Wity S Module build file
I

+---Private

| NeuronBoneMappingWidget.cpp

| NeuronkEditorWindowCommands.cpp

| NeuronEditorWindowStyle.cpp

| NeuronLivelinkEditorModule.cpp

| NeuronLivelinkRemapAssetDetailCustomization.cpp
|

\

---Public
LiveLinkEditorPrivate.h HEL$% [Module interface file
NeuronBoneMappingWidget.h ‘BB L 7 32 T Bone mapping editor UI
NeuronkEditorWindowCommands.h eidtor command
NeuronEditorWindowStyle.h editor style
NeuronLivelinkRemapAssetDetailCustomization.h Neuron 1] & B 5 2
45 2%Remap editor for Neuron

12 FE IR

o SFEFIRIF(rebuild)FRAY TIZRERRiIFEIR Bl IAUHEHERIIETGRIFERIB R UG
%, ELS|IEEEMRIENSMIRXETRE NN SBRT ERmENL, XEELSIE
TRIFRFRIGRIG, TTRRRL ZREN FEEETIE TREPERIIntermediate B R{EAHT
TERYSHHITERR, RGBT (Build) B FHTHEEE Mgithub N ELRRSHRIEHE R

o JEMHIUESS |ZBERFTRRM iEM Marketplace NEfE4HE AEE FEHRE!
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